TADS Bug Database

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000150TADS 3Compilerpublic2012-06-17 21:332012-08-29 00:06
Reporterbcressey 
Assigned ToMichael Roberts 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMacintoshOSMacOSOS VersionX
Summary0000150: t3make -Os generates incomplete list of strings
DescriptionThe t3make -Os option generates an incomplete list of strings, rather than all strings found in all compiled files.

It appears to output only the strings found in _main.t, the first source file in the first included library (system.tl).
Steps To Reproduce1) Add `-Os strings.txt` to Makefile.t3m
2) Run `t3make -clean` to remove compiled files.
3) Run `t3make` to recompile.
4) Output is attached.
TagsNo tags attached.
Fixed In Version3.1.1
Attached Filestxt file icon strings.txt [^] (1,263 bytes) 2012-06-17 21:33 [Show Content]

- Relationships

-  Notes
(0000246)
Michael Roberts (administrator)
2012-06-19 15:02

Fixed for the next update. (I also happened to notice while investigating that the underlying problem also caused internal input file stream corruptions when the build consisted of a large number of modules, which manifested as spurious compiler errors. The underlying bug is that the compiler closed the -Os file handle upon reaching the end of each source module, but then continued to use the now invalid handle. So strings from subsequent files were never added to the -Os file, since its handle was no longer available. The possible stream corruption happened because there was a chance that the closed -OS handle could be reassigned to a subsequent source file; but since the -Os writer still thought it had dibs on the handle, it would keep writing to it, which sometimes corrupted the stream buffer of the source file that thought *it* had dibs. Fortunately the sources were opened in read-only mode, so the actual file contents on disk weren't overwritten.)

- Issue History
Date Modified Username Field Change
2012-06-17 21:33 bcressey New Issue
2012-06-17 21:33 bcressey File Added: strings.txt
2012-06-19 15:02 Michael Roberts Fixed In Version => 3.1.1
2012-06-19 15:02 Michael Roberts Note Added: 0000246
2012-06-19 15:02 Michael Roberts Status new => resolved
2012-06-19 15:02 Michael Roberts Resolution open => fixed
2012-08-29 00:03 Michael Roberts Status resolved => assigned
2012-08-29 00:03 Michael Roberts Assigned To => Michael Roberts
2012-08-29 00:06 Michael Roberts Status assigned => resolved


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker