TADS Bug Database

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000165TADS 3Workbenchpublic2012-08-26 15:092016-03-14 13:07
Reportersimvig 
Assigned ToMichael Roberts 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionunable to reproduce 
PlatformIntelOSWindowsOS Version7
Summary0000165: Crash when running WebUI project for the second time
DescriptionWhen debugging a WebUI enabled project from the workbench, the second run always causes a crash. Opening the workbench again resets the "counter".
Steps To Reproduce1) Create a new project with advanced template and WebUI.
2) Compile and run
3) Terminate the session by closing the interpreter window or from the debugger
4) Run project
5) Crash
TagsNo tags attached.
Fixed In VersionWin119
Attached Filestxt file icon tadscrsh.txt [^] (62 bytes) 2012-11-09 00:49 [Show Content]
zip file icon WestwoodSource.zip [^] (6,910 bytes) 2013-02-05 14:10
zip file icon WestwoodSource2.zip [^] (6,938 bytes) 2013-02-05 14:46

- Relationships

-  Notes
(0000262)
Michael Roberts (administrator)
2012-08-28 19:06
edited on: 2012-08-28 19:06

Fixed; this was an accidental effect of the fix for bug 0000131.

(0000288)
DavidPT (reporter)
2012-11-09 00:49

This crash still happens in version 3.1.2. I have had the game crash on the second or third run of a game.

I have attached the crash file from my most recent crash.
(0000289)
Michael Roberts (administrator)
2012-11-09 01:12

Are you sure you have build Win119 (see the About box in Workbench)? Both Win118 (where the bug was introduced) and Win119 use the same 3.1.2 VM engine.
(0000303)
tberend (reporter)
2013-02-05 14:10

hi, i'm having the same 'crash every other time' problem with Win119, have included the script dump. i'm a complete newbie with TADS, just downloaded it two days ago, so this isn't much of a script (you will recognize the bottom part).

I'm running a Windows 7 box with full HD screen. The basic error says "HTMLDB3.EXE has stopped working". I tried looking for a dump with visual studio but there were no symbols available and source code could not be displayed.

for what it's worth, the unhandled exception was reported at 0x00459cd5 in htmldb3.exe: 0xC0000005: access violation writing location 0X05ad9630.

TADS is an amazing tool, thank you for making it available.
(0000304)
tberend (reporter)
2013-02-05 14:47

pls ignore first zip file and use 0000002. since then I discovered the full-recompile-for-debugging and cleaned up an error. but the crashes are still happening every second or third run.
(0000305)
tberend (reporter)
2013-02-05 15:45

one last note: i downloaded 'ditch day' to study the code (and of course to play it), and re-started it a dozen times without any problem. so the crash does not seem to be my hardware or configuration.
(0000311)
Michael Roberts (administrator)
2013-04-20 02:54

I tried again to reproduce this, this time using Windows 7 / IE 10. Still no luck; I can repeat the run/stop/run/stop cycle apparently endlessly without a problem.

I'm not sure how to proceed with investigating this. It's apparently configuration dependent in that as far as I can tell I'm trying the exact same series of steps with the exact same TADS version and getting different results, so it must be either (a) a subtle difference in the steps we're performing, or (b) something external, such as the OS version, hardware configuration, or third-party software dependencies. Of those the most likely possibility seems to me to be IE, since that's a major third-party software dependency (other than Windows, of course). It is possible that the steps I'm performing aren't perfectly identical to yours - the steps you listed aren't at mouse-click-level detail, so it's possible there's something we're both taking for granted as too obvious to make a difference, but which is nonetheless making a difference.

At any rate, there's not much hope that I can fix it until I can either reproduce it on my machine or get a C++ development environment set up on your machine so we can track it down in a configuration where the bug occurs. Any chance you have the Microsoft C++ tools installed? If so I can get you a debugging build so you can run it under the debugger, and we can see if that sheds any light on what's going on.
(0000312)
Michael Roberts (administrator)
2013-04-20 02:58

Also, I should mention I'm testing with the latest version on the tads.org site - HT-23 (Build Win 119; TADS 3.1.2).
(0000315)
Michael Roberts (administrator)
2013-04-20 14:14

DavidPT reports in bug 0000173 that upgrading to IE 10 seems to fix the problem, so my theory at this point is that the bug is an incompatibility between TADS and IE 9 - so hopefully anyone else having the problem should be able to fix it by upgrading to IE 10. I don't have a Win7/IE9 configuration to test with, so I can't confirm that IE9 is definitely the problem, but given that an IE 10 upgrade fixed the problem on at least one machine where the bug had been occurring, it seems like a good bet.

So, for anyone encountering this problem, if you're on IE 9, please try upgrading to IE 10 if possible and see if that helps. If you do try this, I'd appreciate it if you could update this bug to let us know one way or the other, so anyone else encountering this will know whether or not IE 10 is a likely fix.
(0000407)
DrDiHai (reporter)
2016-03-14 02:25

I believe I have the same issue. Working under Windows 10, which means I'm forced to use IE11. I can't say what would happen with IE10.

The crash doesn't necessarily happen on the second run - sometimes the third or later, sometimes even the first. It does occur after creating the default introductory project.
(0000408)
DavidPT (reporter)
2016-03-14 10:53
edited on: 2016-03-14 13:07

IE10 on Win7 only stopped the crashing for about a week myself. The crash occurs as the Web window is started or closed. If it successfully doesn't crash it doesn't crash while running. It might crash when you stop the simulation and return to coding.

This is leading me to believe the bug might be in how the workbench opens a web window for the game and when it closes it as well.

I've installed Visual Studio 2015 Community and I now have an option to debug when the error occurs. I assume I have the debugger installed now. If this version will work I can try to help you with this bug.


- Issue History
Date Modified Username Field Change
2012-08-26 15:09 simvig New Issue
2012-08-28 19:06 Michael Roberts Fixed In Version => Win119
2012-08-28 19:06 Michael Roberts Note Added: 0000262
2012-08-28 19:06 Michael Roberts Assigned To => Michael Roberts
2012-08-28 19:06 Michael Roberts Status new => resolved
2012-08-28 19:06 Michael Roberts Resolution open => fixed
2012-08-28 19:06 Michael Roberts Note Edited: 0000262
2012-11-09 00:49 DavidPT Note Added: 0000288
2012-11-09 00:49 DavidPT File Added: tadscrsh.txt
2012-11-09 01:12 Michael Roberts Note Added: 0000289
2013-02-05 14:10 tberend File Added: WestwoodSource.zip
2013-02-05 14:10 tberend Note Added: 0000303
2013-02-05 14:46 tberend File Added: WestwoodSource2.zip
2013-02-05 14:47 tberend Note Added: 0000304
2013-02-05 15:45 tberend Note Added: 0000305
2013-04-20 02:54 Michael Roberts Note Added: 0000311
2013-04-20 02:58 Michael Roberts Note Added: 0000312
2013-04-20 02:59 Michael Roberts Resolution fixed => unable to reproduce
2013-04-20 14:14 Michael Roberts Note Added: 0000315
2016-03-14 02:25 DrDiHai Note Added: 0000407
2016-03-14 10:53 DavidPT Note Added: 0000408
2016-03-14 11:11 DavidPT Note Edited: 0000408 View Revisions
2016-03-14 13:07 DavidPT Note Edited: 0000408 View Revisions


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker